cwmobileredirect and cwenvbanner finally available for Typo3 7 LTS

Well, actually the Typo3 7 LTS versions were available for a couple of months through my Github repositories of cwmobileredirect and cwenvbanner already, however I never found the time to upload them to TER. Finally I found some time to upload it, so here you go:

cwmobileredirect on TER
cwenvbanner on TER

The new versions do not include any new features, I did some cleanup though, so Typo3 4.x is no longer supported. Please just stick with the old versions of the extensions in case you are still using one of these ancient Typo3 installations.

Besides Typo3 7 compatibility and cleanup I spend some time on making them work with a Composer based Typo3 installation (the outcome can be found on Github as well) and Travis CI. Since I only work on these extensions occasionally, this will surely help me in with the Typo3 8 LTS versions (which I hope to get done a bit earlier this time :-)).

3 thoughts on “cwmobileredirect and cwenvbanner finally available for Typo3 7 LTS”

  1. Hey Carsten, nutze deine Extension “cwmobileredirect” schon bereits in der TYPO3 4.5 Version. Habe dann vor kurzem ein TYPO3 Update von der 6.2 -> 7.6 durchgeführt und seitdem greift die Condition im TypoScript nicht mehr [userFunc = user_isMobileForced]. Hatte vorher bereits im TypoScript die Condition drinne gehabt (in der 6.2 Version) und deine Extension über Composer auf die 1.5 Version geupdated und eben TYPO3 auf die 7.6 Version. Jetzt muss ich aber feststellen, dass die Condition nicht greift d.h. der kommt leider gar nicht in die Funktion “user_isMobileForced”. Hast du in der 7.6 Version die Extension auch mal zum laufen gebracht. Vielen Dank schon einmal für dein Feedback

    1. Danke für Dein Feedback, Dominik! Ja, die Extension ist schon ziemlich alt…

      Bezüglich Deines Problems, vor kurzem (naja, auch schon wieder 2 Monate her) wurde ein Bug bezüglich der User-Functions gefixt, ich denke das sollte Dir helfen:

      https://github.com/carstenwindler/cwmobileredirect/issues/4

      Ich habe allerdings, wie ich gestehen muss, noch keine Zeit gefunden, diesen Bugfix also neue Version im TER zu veröffentlichen, also müsstest Du bitte den letzten commit vom master branch nehmen.

  2. Erst einmal danke dir für die schnelle Rückmeldung und den Tipp 😀 Ja das ist mir auch aufgefallen, dass die Class nicht geladen wird.

    Super Danke dir habe es jetzt eingebunden über Composer mit deinem Repo bei github 😉

Leave a Reply

Your email address will not be published. Required fields are marked *